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Crystal structure solution by direct space methodsCrystal structure solution by direct space methods
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Structure solutionStructure solution

Structure
 solution

Traditional approaches:

direct methods
Patterson methods
charge flipping

Direct space methods

Alternative words:real space, 
global optimization, global search

Popular and widely available in recent years
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Complexity of the problem 
depends on the number of 
atoms in the a.u.

Complexity of procedure depends on
the number of degrees of freedom. 
Can solve structures too large for 
being refined

Do not use chemical knowledge Can incorporate a massive amount
of prior chemical information

ComparisonComparison

Traditional approaches Direct space methods
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Take time and patience. For large 
molecules: faster computer, run 
overnight

Generally require less time to run

ComparisonComparison

Direct-Space methodsTraditional approaches

High resolution is not needed.
2-2.5 Å resolution is enough

Take advantage by using
data of higher resolution
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Global optimization methodsGlobal optimization methods

Global mimimum x*

Local mimimum

F:ℝn→ℝFind x*= min{F(x)}, where 

Local optimization methods Structure refinement

Global optimization methods Structure solution

X = fractional coordinates of (x,y,z)       or       

X = postion (x,y,z), orientation (θ, φ, ψ), torsion angles (τ
1
, τ

2
, … τ

n
) of molecular fragments
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Global optimization methodsGlobal optimization methods

Genetic Algorithms *
Simulated Annealing *
Tabu Search
Ant Colony Optimization
Particle Swarm Optimization *
Bee Algorithms
Firefly Algorithms
Harmony Search
Big Bang-Big Crunch *
…...............................

Deterministic methods
Branch and Bound methods
Cutting Plane methods
Interval methods
…..................

Heuristic strategies

(*) employed in solving crystal structure

Widely used and with 
the largest impact

 
Various modifications: 

parallel tempering
adaptive simulated annealing
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Simulated annealingSimulated annealing

Metropolis: is 
new configuration

better than the previous?

Initial random configuration

Generate trial structure by 
random displacement of 

structural variables

Evaluate the cost function 
(CF) for trial structure

Yes (ΔCF < 0).
Keep new configurationNo  (ΔCF > 0) 

Accept new
Configuration if

exp(-ΔCF/T) > RND

ΔCF = CF
new

- CF
old

RND = random number
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Big bang phase
Creation of the population 

expansionexpansion contractioncontraction

Candidate solutions are spread all 
over the search space in a uniform 
manner. Cost function values of 
the individuals are calculated

Big crunch phase
Center of mass is calculated and
chosen as the point of new big
bang phase

Big bang-big crunch optimizationBig bang-big crunch optimization

Hybrid versionHybrid version: SA is applied on selected individuals before the big crunch: SA is applied on selected individuals before the big crunch
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Building starting modelBuilding starting model

It is necessary to know the molecular connectivity. 
Spectroscopic techniques (MS, NMR) can be useful 

Crystal structure can be described as a combination of building blocks

atom molecule polyhedron
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Building starting modelBuilding starting model

Check for similar molecules in databases or in the literature,

use tables of standard bond lengths 

(volume C of International Tables for X-Ray Crystallography)

Optimize molecular geometry by computational chemistry 

programs
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Crystal Structure DatabasesCrystal Structure Databases

CSD (Cambridge Structural Database) (organics & organometallics):

http://www.ccdc.cam.ac.uk/

ICSD (Inorganic Crystal Structure Database) 

(inorganics, elements, minerals & intermetallics): http://icsd.ill.fr/

COD (Crystallography Open Database) (general database): 

http://www.crystallography.net/

Other databases: ICDD PDF-4+, American Mineralogist Crystal Structure 
Database,  MINCRYST, Zeolite Structures Database, ... 

Non-commercial database are in red

File format: CIF (Crystallographic Information File)
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Free Chemistry DatabasesFree Chemistry Databases

PubChem: https://pubchem.ncbi.nlm.nih.gov/

NIST Chemistry WebBook: http://webbook.nist.gov/chemistry/

Drugbank: http://www.drugbank.ca/

Other databases: ZINC, eMolecules, ChEBI, NMRShiftDB, ...

Chemical file formats: sdf, mol, mol2, cml, SMILES

2D molecular structures must be optimized before being 
used for structure solution
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Geometry optimizationGeometry optimization

Three levels of theory

Molecular-mechanics force fields

Semi-empirical methods

Ab initio methods: self-consistent field (SCF), density 
functional theory (DFT)

Programs: MOPAC, Gamess, NWChem, Gaussian, ABINIT, etc.
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Molecule editorMolecule editor

Sketch molecules in 2D or 3D format 

Optimize the geometry by force field method 

Create input file for the quantum-chemistry calculations 

Read output files of the most common computational packages 

ACD/ChemSketch -  http://www.acdlabs.com 

Avogadro - http://avogadro.openmolecules.net/wiki/Main_Page

MarvinSketch -  http://www.chemaxon.com/products/marvin/

Gabedit: http://gabedit.sourceforge.net/

Some free available software

A molecular editor allows
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Geometry optimization and Geometry optimization and EXPO2014EXPO2014

Molecular-mechanics force fields (MMFF99 and UFF provided by 
Open Babel library)

Graphical interface of MOPAC

Able to process input and output files of the most common 
quantum-chemistry packages
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Building starting model: example 1Building starting model: example 1

3D structure optimization

P 21/a

2-(4-Hydroxy-2-oxo-2,3-dihydro-1,3-benzothiazol-7-yl)
ethylammonium chloride N

frag
 = 2

Ndof = 6 + 3 + 2

Save as 
.mol, .mol2,
.fhz, .mop, 
.cif, .pdb, .frac
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Building starting model: example 2Building starting model: example 2

3D structure optimization

P c a 21 N
frag

 = 2
N

dof
 = 6 + 6 + 3 + 3

 3-chloro-1,3,4-triphenyl-azetidin-2-one
Two molecules in the a.u.

Save as 
.mol, .mol2,
.fhz, .mop, 
.cif, .pdb, .frac
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Building starting model: example 3Building starting model: example 3

P 21/a

3D structure optimization

N
frag

 = 1
N

dof
 = 6 + 7

1,4-Bis(2-phenethyloxyethanesulfonyl)piperazine

center of symmetry

a.u. is a half molecule



  

 

  

Bruker OpenLab Albania  30 May - 3 June 2016

19/43

famotidine form B

P 21/c

3D structure optimization

Building starting model: example 4Building starting model: example 4

N
frag

 = 1
Ndof = 6 + 6
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Building starting modelBuilding starting model

Stereochemistries will not be altered during simulated annealing.
Attention to compounds with more than one chiral center and cis/trans isomerism

Attention to non planar ring systems or unusual combinations of elements in functional
groups. Check for similar molecules in the CSD or in the literature

or or

trans cis
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Building starting modelBuilding starting model

Check V
cell

/V
mol

V
mol

 = number of non-hydrogen atoms · 18   (18 Å3 rule)

∑ ni viV
mol

 = 

or

The volume of the unit cell can be used to determine the 
number of independent building blocks in the asymmetric unit 
from the known crystal density

Average volume occupied by atom ≈ 15 – 20 Å3 

The success of the structure determination depends crucially on the 
accuracy of the input molecular model. 

Experience and chemical intuition are required to build the correct model

n
i
 = number of atoms of the ith type in the structure

v
i
 = volume contribution (in Å3) for the ith atom type
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Cost functionCost function

CF=RW P=√
∑

i

w i(yobs(θi)−ycalc(θi))
2

∑
i

wi yobs(θi)
2

Calculated in the range 2θ
0
 - f·FWHM < 2θ

i 
< 2θ

0
 + f·FWHM, with f=1

There is no need to extract the intensities I
hkl

 

Weighted-profile  R value (R
wp

)

Bragg intensity R value (R
B
)

CF=RB=
∑

h

∣Ih
obs

−Ihkl
calc∣

∑
h

Ihkl
exp

I
h
obs are the integrated intensities by Le Bail decomposition method

The advantage of this approach is that it offers a reduction in the computation time
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Simulated annealing optionsSimulated annealing options

Cost function

Starting temperature

Temperature reduction factor

Number of SA runs

Number of moves 

Resolution

Random seed
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H atomsH atoms

H atoms do not contribute significantly to diffraction, they can 
be ignored during the structure solution.

amodiaquinum dichloride dihydrate

with H atoms without H atoms
Number of atoms 57 29
External DoFs 6+6+6+3+3=24 6+3+3+3+3=18
Internal DoFs 9 6
Time 25h 59m 10h 53m

40 30
RMSD 0.0116 0.0294
Success (%,20 runs)
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H atomsH atoms

The interpretation of the correctness of crystal structure is far 
easier when the H atoms are present

Eliminating the H atoms reduces the number of atoms and DoFs, 
decreasing the time to evaluate CF for each
trial structure

How to delete the hydrogens?

Collectively, their contribution to the overall scattering can be significant
and they should be included in the molecular model whenever possible
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Hydrogen calculationHydrogen calculation

Hydrogen atoms are positioned geometrically
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Using expo2014 for direct-space solutionUsing expo2014 for direct-space solution

By input file (*.exp)By input file (*.exp)

%Structure paracetamol
%Job Paracetamol  (C8H9NO2)
%Data
   Cell  7.100  9.380  11.708  90.0  97.42  90.0
   SpaceGroup p 21/n
   Pattern   paracetamol.xy
   Wavelength 1.54056
%fragment paracetamol.mol
%sannel

File > Load & Go

Command-line usageCommand-line usage
expo paracetamol.exp
or
expo paracetamol.exp –nogui
or
expo paracetamol.exp –auto  
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Using expo2014 for direct-space solutionUsing expo2014 for direct-space solution

File > Import Diffraction Pattern 

File > Import Structure

Solve > Simulated Annealing

By graphical interface

Modify > Add Fragments
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Non-molecular compoundsNon-molecular compounds

Some atoms are expected to fall on special position

Different building blocks share some atoms

You cannot know the number and the type of the polyhedra
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Dynamical occupancy correction (DOC)Dynamical occupancy correction (DOC)

Occupancy−1=1+ ∑
neighbour

|dmin−di|

Falcioni, M. & Newsam, J. M. (1989). Nature 342, 260-262.

Favre-Nicolin, V. & Černỳ, R.  (2002). J. Appl. Cryst.. 35, 734-743

d
min

=1 Å

occupancy

DOC is able to merge the excess atoms automatically
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Dynamical occupancy correction (DOC)Dynamical occupancy correction (DOC)

DOC slows down the computation time so it should be avoid DOC slows down the computation time so it should be avoid 
if no special positions or shared atoms are expected.if no special positions or shared atoms are expected.
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SA applied to non-molecular compoundsSA applied to non-molecular compounds

Sb2(PO4)3

Polyhedra rapresentation of Sb2(PO4)3  
by SA with DOC

SA with DOCSA with DOC
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Delete duplicate atomsDelete duplicate atoms

29 atoms

2 atoms

2 atoms

2 atoms

17 atoms

*

symmetry equivalent atoms *

1.  Modify > Delete Duplicate Atoms
2. Tools > Build Bonds

2 atoms *
*

*
*

*

*

*
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Assessing the solutionAssessing the solution

Reproducibility of solution

Agreements factors
Visual match between calculated and observed profile
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Display difference Fourier map  (at least 1.5 Å resolution data) 

Assessing the solutionAssessing the solution

correct structurecorrect structure

wrong structurewrong structure
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Assessing the solutionAssessing the solution

Crystal packing

Network of interactions: hydrogen bonds and short contacts

Check close contacts, void spaces, likely iterations

DFT-D (plane wave density functional theory with dispersion correction):

CASTEP (http://www.castep.org/),
VASP (https://www.vasp.at/)

Two programs:
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Imposing restraints Imposing restraints 

CF=CF+∑i wiMAX (0.0,∣dtarget i
−dABi

∣− toli)
2

dABi
    = distance between two atoms A and B

dtargeti
= ideal distance

tol
i
 = permitted tolerance

w
i
 = user supplied weight

Rarely improve the success rate of the solution search for good quality data

Directive: 

res  A  B  d
target

 tol  w

d
target 

and tol are optional: 

res  A  B

Restraints can slow or prevent a structure solution
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Imposing anti-bumping restraints Imposing anti-bumping restraints 

CF=CF+∑i wij(dij
min−dij

model)2k

dmodel<dmin

dij
min=ϵ(Ri

0+R j
0)

R0=vander Waals radius

.........
%sannealing

bump
.........

Directive bump

Warning: time-consuming procedure, use only 
if the diffraction data are not of sufficient quality

P c a 21
Electron diffraction

k = 2
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Starting model is incorrect: 

chemical formula is wrong
bond distances and angles are not entirely accurate
number of building blocks is wrong
missing solvent
  …................  

Check the compositional information (MS, SEM/EDS, XRF, ICP, NMR)
Try different combination of building blocks
Check the molecular stereochemistry or the ring conformation
Improve your model with CSD or building package 

Solution:Solution:

When Structure Solution FailsWhen Structure Solution Fails
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Poor quality diffraction pattern

When Structure Solution FailsWhen Structure Solution Fails

Collect new data
Add restraints or anti-bump restraints

Systematic problems in powder diffraction data

Solution:Solution:

Collect new data
Refine preferred orientation parameter

Solution:Solution:

Preferred orientation
Kα2 contributions
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When Structure Solution FailsWhen Structure Solution Fails

For complex structure (internal DOF > 10) the default SA 
conditions may not be sufficient

Solution:Solution:
Increase the number of moves and/or runs
Try with slower temperature reduction

The assumptions about thermal factors are invalid 

Solution:Solution:
Try altering the non-hydrogen atom temperature factors
Check temperature factors for similar structure
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When Structure Solution FailsWhen Structure Solution Fails

Space group and cell are not correct

Solution:Solution:
It may be necessary to carry out a series of independent calculations 
to test different potential space groups and/or unit-cell choices
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Thank you 
for your attention
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Exercise 1 – structure determinationExercise 1 – structure determination  of  of P(CP(C
66HH55))33  

Perform all the steps of the crystal structure 
determination of the Triphenylphosphine
Wavelength: 1.000972 (synchrotron radiation). 
Data file: exercise 1/pph3.xy

 P(C6H5)3

Save the final model as pph3.mol, in mol file format

Compare the final model with the published model pph3_pub.cif 
in the folder exercise 1/solution (Tools → Overlay structures)

Difficult level: easy

Tips 
File > Import Diffraction Pattern 
Pattern > Range (2-theta max = 60°)
Pattern > Indexing
Z = 4
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Exercise 2 – structure determinationExercise 2 – structure determination  of  of CC3636HH3030ClCl22NiPNiP22  
Difficulty level: hard

Load the input file nickel.exp (File → Load & 
go), determine the space group and solve the 
structure by using the Direct Methods

If direct methods fail apply the RAMM technique or 
the alltrials procedure 

Save your best model in a nickel_part1.cif format

Part 1Part 1

Tip
correct space group is P 2/c 
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Solve the structure using the real space technique:

Use the polyhedra tool to visualize
the tetrahedral coordination of Ni

Part 2Part 2

Exercise 2 – structure determinationExercise 2 – structure determination  of  of CC3636HH3030ClCl22NiPNiP22  
Difficulty level: hard

1.Import the pph3.mol file created in the exercise 1 (File → Import)
2.Add one Ni and one Cl in random position 

(Modify → Add   fragments → Isolated Atoms)
3.Run Simulated Annealing (Solve → Simulated Annealing)
4.Apply DOC on Ni atom 

Compare the best solution of SA (nickel_best1.cif)
with the nickel_part1.cif


